FAQ - Action Engine
If users can not access the 'My Inbox' page, the corresponding permissions are missing. See User Roles for further information on how to set these permissions.
If your Skill does not produce any Signals, this might be due to different reasons. Therefore:
First, check if your Skill produces any Signals at all in the Skills configuration
Second, check if the execution was successful on the Skills overview page
Third, check if the relevant business user is part of the respective Routing Rule determining which user should see which Signal.
Go to the Skills page, then you can find the last execution date of the respective Skill in the column “Last Execution”.
Check the following aspects:
Are the corresponding Data Models loaded? If not, reload it.
Does the Skill preview work? If not, check for errors in the filters or table statements.
If you are routing the Signals based on Data Model column, first check if the column is chosen from the same Data model. Check the Routing Table preview.
If this results in an error, this is might be related to the chosen Signal ID. Action Engine is trying to filter on the Signal ID of your signals. Contact the Support through the Support portal to describe this problem.
The first thing to check is if the users are part of the routing rule.
If the user is part of the routing rule, and you are routing the Signals based on Data Model column check the Routing Table preview.
If this results in an empty table, this is related to the chosen Signal ID. Action Engine is filtering on the Signal ID of your signals, which can result in problems for floating values and timestamps that actually exhibit millisecond precision as part of the Signal ID. If you can round numbers to integers and timestamps to seconds, this should solve the issues.
If the preview looks okay, but still you are missing some Signals, this can happen if actually filtering uniquely on your signals is impossible. Try to add a unique identifier that one can filter on.
Check if the name of the column in the Signal configuration is still corresponding with the name of your placeholder. If not, please delete the placeholder and add it again.
Probably the Data Model is not loaded, please check the availability of your data model.Alternatively, check if the placeholder statement is still correct. When changing Signal attributes or their data type, this might result in an error for the Filter Template.
Whenever you change the definition of your Signal ID, the Filter Template for your Details Table is automatically overwritten.
When you allow users to use the "Mark as Resolved" and "Delete" workflow steps for Signals (which you can optionally do in the Skill settings), they can mark Signals as resolved or deleted manually. However, this only operates on a Signal's record in the Action Engine database. Housekeeping also only deletes the record for a resolved Signal from the Action Engine database.
So if a Signal has been marked as resolved or deleted by a user and then cleaned up by Housekeeping, the corresponding entry can still exist in the Data Model. When Action Engine next looks up the Data Model, it finds the entry. Then because there is no longer a Signal for it in the Action Engine database, it creates a new Signal, causing the deleted Signal to reappear.
To prevent this, add a Duration Filter to the Skill configuration that filters the Data Model by date, with a duration matching the Housekeeping setting (which defaults to 180 days). That way, the entries in the Data Model are not searched beyond the Housekeeping time limit, so they will not reappear as new entries after that time.
Yes, you can execute several dependent queries on one Data Model. The easiest way to implement this is to use the pipelining function and execute several steps.
We recommend the following two-step workflow to systematically omit and exclude Signals for certain attribute constellations.
The business user can request the exclusion of a given attribute via the Feedback button as shown in the picture. The user should provide reasoning such that the Analyst and Skill owner can judge the validity of the request.
The Skill owner will receive an email with the feedback. The feedback will also be shown in the skill configuration. Having checked the request, the Skill owner can add an additional filter in the Skill definition, e.g. a Column Filter excluding certain values
You might notice that the skills deleted from a project are still shown on the data extracted from Action Engine using the Action Engine connector. These details can be still seen on the SKILL table.
Problem
Suppose you delete the "test" skill from Action Engine Project.
You look at the "Skill" table from the extracted data using the Action Engine connector, and you can see a row for the deleted skill.
You won't see any errors, but the deleted skill is still shown in the Action Engine extracted data.
Cause
This is how the DELTA extraction works with respect to Action Engine.
Once a skill has been deleted, the skill still exists in the Data Pool, but it is no longer extracted in the DELTA loads.
As we can see below, the last DELTA extraction was completed at 12:55, but this row for "test" is not extracted during this extraction which still has the date of last extraction when the skill was still available.
Solutions
Though not really recommended, one way to delete the row also on the SKILL table is to perform a FULL load, but ”Full Load” mode will delete all existing data and replace it with newly extracted data. The data from Action Engine already cleaned by Housekeeper will not be available anymore.
The other way is to delete the data related to the skill using DELETE queries in a transformation.